V I V E R E S T A Y S

 

Yes, SaasLand is compatible with WordPress 5.0 and higher versions.